server_client_comm 0.1.7

  • Readme
  • Changelog
  • Installing
  • 3

This package lets you communicate between the server and client, all you need to do is SocketMessage.shrinkT(x,[y]) to turn x into json and make y it's type and SocketMessage.expandT(x) to turn the json string x into an object.

this package uses dson.

¯\_(ツ)_/¯

did stuff i guess

0.1.5:

  • changed expandTransform to SocketMessage.expandT (static)
  • changed shrinkTransform to SocketMessage.shrinkT (static)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  server_client_comm: ^0.1.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:server_client_comm/server_client_comm.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
10
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
3
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms:

Low code quality prevents platform classification.

Health issues and suggestions

Fix lib/src/sccomm.dart. (-90.09 points)

Analysis of lib/src/sccomm.dart failed with 8 errors, 2 hints, including:

line 49 col 33: Undefined name 'JSON'.

line 53 col 19: Undefined name 'JSON'.

line 58 col 20: Undefined name 'JSON'.

line 61 col 45: The method tear-off 'expandT' has type 'dynamic Function(String)' that isn't of expected type 'dynamic Function(dynamic)'. This means its parameter or return type doesn't match what is expected.

line 64 col 44: The method tear-off 'expandT' has type 'dynamic Function(String)' that isn't of expected type 'dynamic Function(dynamic)'. This means its parameter or return type doesn't match what is expected.

Format lib/server_client_comm.dart.

Run dartfmt to format lib/server_client_comm.dart.

Format lib/src/typesOfSame.dart.

Run dartfmt to format lib/src/typesOfSame.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: dson.

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

Package is getting outdated. (-98.90 points)

The package was last published 103 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and server_client_comm.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The description is too long. (-10 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <3.0.0
dson any 0.16.0
Transitive dependencies
analyzer 0.38.5
args 1.5.2
async 2.4.0
build 1.2.0
built_mirrors 0.11.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.3
csslib 0.16.1
dart_style 1.3.1
front_end 0.1.27
glob 1.1.7
html 0.14.0+3
kernel 0.3.27
logging 0.11.3+2
meta 1.1.7
package_config 1.1.0
path 1.6.4
pedantic 1.8.0+1
pub_semver 1.4.2
serializable 0.12.0
source_gen 0.9.4+5
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.2.0