selectable_circle 0.1.6+3

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

selectable_circle #

A Flutter package for an Circle that can be Selected with animation.

How to use #

SelectableCircle(
    width: 80.0,
    onSelected: () {
    setState(() {
        _isSelected = !_isSelected;
    });
    },
    child: Icon(Icons.star),
);

Screenshot #

Parameters #

    /// the width and height of the CircleWidget
final double width;

/// is called when the circle is tapped
final VoidCallback onSelected;

/// child displayed on top of the circle
final Widget child;

/// widget should be displayed as selected
final bool isSelected;

/// Color of the circle
final Color color;

/// borderColor of the circle
final Color borderColor;

/// Color of the circle when selected
final Color selectedColor;

/// Color of the border when selected
final Color selectedBorderColor;

/// widget that is displayed below the Circle for descriptions
final Widget bottomDescription;

/// changes the select animation
///
/// Possible Values:
/// simple: no animation, only selectedColor is used
/// animatedCircle: Animation is used (default)
/// check: Check Icon Animation is used
final SelectMode selectMode;

[0.0.1] - Test release

  • Test release for trying paths and so on

[0.1.0] - First release

[0.1.6+3] - Dependency Update

  • Updating dependencies because flare changed indices to match dart.ui

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  selectable_circle: ^0.1.6+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:selectable_circle/selectable_circle.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
72
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flare_dart).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0-dev.0.1 < 3.0.0
flare_dart ^1.4.4 1.4.9 2.2.2
flare_flutter ^1.5.5 1.5.13 1.6.2
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test