seeyou_service 1.0.4

seeyou_service #

A new Flutter plugin.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.

example/README.md

seeyou_service_example #

Demonstrates how to use the seeyou_service plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  seeyou_service: ^1.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:seeyou_service/seeyou_service.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
13
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

40 out of 40 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/foundation_ext/type_converter.dart. (-1.99 points)

Analysis of lib/foundation_ext/type_converter.dart reported 4 hints:

line 2 col 6: Name non-constant identifiers using lowerCamelCase.

line 19 col 8: Name non-constant identifiers using lowerCamelCase.

line 26 col 5: Name non-constant identifiers using lowerCamelCase.

line 42 col 8: Name non-constant identifiers using lowerCamelCase.

Fix lib/service_template.dart. (-1 points)

Analysis of lib/service_template.dart reported 2 hints:

line 8 col 17: Name types using UpperCamelCase.

line 21 col 19: Don't explicitly initialize variables to null.

Format lib/foundation_ext/foundation_ext.dart.

Run flutter format to format lib/foundation_ext/foundation_ext.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/seeyou_service.dart (Run flutter format to format lib/seeyou_service.dart.)
  • lib/service_call_handler.dart (Run flutter format to format lib/service_call_handler.dart.)
  • lib/service_gateway.dart (Run flutter format to format lib/service_gateway.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field http://phabricator.meiyou.com/diffusion/67/ was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test