sdk_ble_flutter 0.1.5+105

  • Readme
  • Changelog
  • Example
  • Installing
  • 40

xyo_ble #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.5 #

Added Example Project

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sdk_ble_flutter: ^0.1.5+105

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sdk_ble_flutter/channels/bridge.dart';
import 'package:sdk_ble_flutter/channels/device.dart';
import 'package:sdk_ble_flutter/channels/node.dart';
import 'package:sdk_ble_flutter/channels/sentinel.dart';
import 'package:sdk_ble_flutter/classes/archivist.dart';
import 'package:sdk_ble_flutter/main.dart';
import 'package:sdk_ble_flutter/protos/bound_witness.pb.dart';
import 'package:sdk_ble_flutter/protos/bound_witness.pbenum.dart';
import 'package:sdk_ble_flutter/protos/bound_witness.pbjson.dart';
import 'package:sdk_ble_flutter/protos/bound_witness.pbserver.dart';
import 'package:sdk_ble_flutter/protos/device.pb.dart';
import 'package:sdk_ble_flutter/protos/device.pbenum.dart';
import 'package:sdk_ble_flutter/protos/device.pbjson.dart';
import 'package:sdk_ble_flutter/protos/device.pbserver.dart';
import 'package:sdk_ble_flutter/protos/gatt.pb.dart';
import 'package:sdk_ble_flutter/protos/gatt.pbenum.dart';
import 'package:sdk_ble_flutter/protos/gatt.pbjson.dart';
import 'package:sdk_ble_flutter/protos/gatt.pbserver.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Oct 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/channels/sentinel.dart.

Run flutter format to format lib/channels/sentinel.dart.

Format lib/main.dart.

Run flutter format to format lib/main.dart.

Format lib/protos/bound_witness.pb.dart.

Run flutter format to format lib/protos/bound_witness.pb.dart.

Fix additional 11 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/protos/bound_witness.pbenum.dart (Run flutter format to format lib/protos/bound_witness.pbenum.dart.)
  • lib/protos/bound_witness.pbjson.dart (Run flutter format to format lib/protos/bound_witness.pbjson.dart.)
  • lib/protos/bound_witness.pbserver.dart (Run flutter format to format lib/protos/bound_witness.pbserver.dart.)
  • lib/protos/device.pb.dart (Run flutter format to format lib/protos/device.pb.dart.)
  • lib/protos/device.pbenum.dart (Run flutter format to format lib/protos/device.pbenum.dart.)
  • lib/protos/device.pbjson.dart (Run flutter format to format lib/protos/device.pbjson.dart.)
  • lib/protos/device.pbserver.dart (Run flutter format to format lib/protos/device.pbserver.dart.)
  • lib/protos/gatt.pb.dart (Run flutter format to format lib/protos/gatt.pb.dart.)
  • lib/protos/gatt.pbenum.dart (Run flutter format to format lib/protos/gatt.pbenum.dart.)
  • lib/protos/gatt.pbjson.dart (Run flutter format to format lib/protos/gatt.pbjson.dart.)
  • lib/protos/gatt.pbserver.dart (Run flutter format to format lib/protos/gatt.pbserver.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/XYOracleNetwork/sdk-ble-flutter was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (protobuf).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
fixnum ^0.10.9 0.10.9
flutter 0.0.0
protobuf ^0.13.15 0.13.16+1 1.0.0
synchronized 2.1.0+1 2.1.0+1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
build_runner ^1.0.0
flutter_test