scrollable_image_view 0.0.5

scrollable_image_view #

A scrollable image view.

Usage #

Basic Usage #

Show the image with original size.

  imagePath: "hoge.png",
  viewSize: Size(width: 400, height: 400),

Set image size #

Show the image with specified size.

  imagePath: "hoge.png",
  viewSize: Size(width: 400, height: 400),
  imageSize: Size(width: 600, height: 400),

Set image scale #

Show the image scaled by imageScale.

  imagePath: "hoge.png",
  viewSize: Size(width: 400, height: 400),
  imageScale: 3.0,

[0.0.5] - Fix bar duplication bug

  • Fix problem about scroll bar

[0.0.2] - Update README

  • Add usage description on README

[0.0.1] - Release first version

  • Implement basic feature

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  scrollable_image_view: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:scrollable_image_view/scrollable_image_view.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and scrollable_image_view.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies