scoped_model 1.1.0
scoped_model: ^1.1.0 copied to clipboard

A Widget that passes a Reactive Model to all of it's children

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add scoped_model

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  scoped_model: ^1.1.0

Alternatively, your editor might support or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:scoped_model/scoped_model.dart';
176
likes
110
pub points
97%
popularity

A Widget that passes a Reactive Model to all of it's children

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on scoped_model