scarabei_reyer 4.0.1

scarabei_reyer #

Pub Package GitHub Issues GitHub Forks GitHub Stars GitHub License

Default implementations if the scarabei API


    L.installComponent(new SimpleLogger()); //logger
    Err.installComponent(new RedError()); //errors reporter
    Debug.installComponent(new RedDebug()); // asserts for debug and testing
    Utils.installComponent(new RedUtils()); //utils including the path-factory

      //here we install a Windows file-system
      LocalFileSystem.installComponent(new WinFileSystem());
      //Windows is POSIX now too
      LocalFileSystem.installComponent(new UnixFileSystem());
      // Android
      LocalFileSystem.installComponent(new AndroidFileSystem());
      //This was the last line where we cared about the filesystem type (PISIX/Windows)
      //From this moment onwards, the path works in a generic way.


    Json.installComponent(new DartJson());
    Strings.installComponent(new RedStrings()); // some utils for strings
    Sys.installComponent(new RedAndroidSystem()); //...
    SystemSettings.installComponent(new RedSystemSettings()); //...
    SystemSettings.setExecutionMode(ExecutionMode.EARLY_DEVELOPMENT); // activate debugging flags
    SystemSettings.setExecutionMode(ExecutionMode.PUBLIC_RELEASE); // deactivate production mode

    MD5.installComponent(new RedMD5());

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  scarabei_reyer: ^4.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:scarabei_reyer/scarabei_reyer.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0