save_image 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 81

save_image #

A new Flutter plugin. OC + Kotlin Language

Permission #

  • Android #

Add the following statement in AndroidManifest.xml:

<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
  • iOS #

Add the following statement in Info.plist

<key>NSPhotoLibraryUsageDescription</key>
<string>Modify the description of the permission you need here.</string>

example #

    var response = await Dio().get(url, options: Options(responseType: ResponseType.bytes));
    bool isSaveSuccess = await SaveImage.save(imageBytes: Uint8List.fromList(response.data));

0.0.1 #

  • TODO: Describe initial release.

0.0.2 #

  • add exapple

1.0.0 #

  • change version

1.0.1 #

  • add Permission Description

example/lib/main.dart

import 'dart:typed_data';

import 'package:dio/dio.dart';
import 'package:flutter/material.dart';
import 'package:save_image/save_image.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'SaveImage Demo'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);
  final String title;
  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  void _saveImage() async {
    var response = await Dio().get(
        "https://camo.githubusercontent.com/b979458fae89f97f0e646d395935a5e8970e239e/687474703a2f2f71696e69752e636d703532302e636f6d2f6b6566757869746f6e682e6a7067",
        options: Options(responseType: ResponseType.bytes));
    bool isSaveSuccess =
        await SaveImage.save(imageBytes: Uint8List.fromList(response.data));
    print(isSaveSuccess ? "save success" : 'save fail');
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            RaisedButton(
              onPressed: _saveImage,
              child: Text("save Photo"),
            )
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  save_image: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:save_image/save_image.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:save_image/save_image.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:save_image/save_image.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:save_image/save_image.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:save_image/save_image.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [save_image] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test