santhoshi_library 1.0.9

  • Readme
  • Changelog
  • Installing
  • 28

A sample command-line application.

Created from templates made available by Stagehand under a BSD-style license.

1.0.8 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  santhoshi_library: ^1.0.9

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:santhoshi_library/map_library.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
73
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Fix bin/main.dart. (-25.38 points)

Analysis of bin/main.dart failed with 1 error, 1 hint:

line 1 col 8: Target of URI doesn't exist: 'package:DartLibrary/DartLibrary.dart'.

line 1 col 50: Use lowercase_with_underscores when specifying a library prefix.

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/map_library.dart. (-0.50 points)

Analysis of lib/map_library.dart reported 1 hint:

line 3 col 11: The declaration 'readMe' isn't referenced.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://NagaSanthoshi@bitbucket.org/NagaSanthoshi/santhoshidartlibrary.git was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and santhoshi_library.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
Dev dependencies
pedantic ^1.0.0
test ^1.0.0