sanjagh_flutter 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

sanjagh_flutter #

A new Flutter plugin.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.4 #

bug fixes and improvements.

0.0.3 #

pass error code to AdListener

0.0.2 #

some bug fixes and improvements

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:sanjagh_flutter/sanjagh_flutter.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    SanjaghFlutterPlugin.instance.initialize("bOwX7fTsz10X7TXQ1HcFvqldUgcvFfpP", market: SanjaghFlutterPlugin.MARKET_GOOGLE_PLAY, primaryColor: "#c44d47", userIdentifier: "Hossein");

    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion = "5";
    // Platform messages may fail, so we use a try/catch PlatformException.
//    try {
//      platformVersion = await SanjaghFlutterSdk.platformVersion;
//    } on PlatformException {
//      platformVersion = 'Failed to get platform version.';
//    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  InterstitialAd _interstitialAd;
  BannerAd _bannerAd;

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: getListView(),
//        body: Center(
//          child: Column(
//            children: <Widget>[
//              SizedBox(
//                width: 400,
//                height: 200,
//                child: BannerAdView(
//                  adUnitId: "5mytHpN4fBGHsNoo",
//                  adListener: (AdEvent event) {
//                    print(event);
//                  },
//                ),
//              ),
//              SizedBox(
//                width: 400,
//                height: 200,
//                child: BannerAdView(
//                  adUnitId: "n6kPN0Ymsz8QeUR4",
//                  adListener: (AdEvent event) {
//                    print(event);
//                  },
//                ),
//              ),
//              RaisedButton(
//                child: Text('load'),
//                onPressed: () {
//                  bannerAd.load();
//                },
//              ),
//            ],
//          ),
//        ),
      ),
    );
  }
}

List<String> getListElements() {
  var items = List<String>.generate(100, (counter) => "Item $counter");
  return items;
}

Widget getListView() {
  var listItems = getListElements();

  var listView = ListView.builder(itemBuilder: (context, index) {
    if (index % 10 == 9) {
      return SizedBox(
        width: 100,
        height: 60,
        child: BannerAdView(
          adUnitId: "dMw6clFB4YCv9B0C",
          adListener: (AdEvent event, int errorCode){
            print("$event:$errorCode");
          },
        ),
      );
    }
    return ListTile(
      leading: Icon(Icons.arrow_right),
      title: Text(listItems[index]),
      onTap: () {
        debugPrint('${listItems[index]} was tapped');
      },
    );
  });

  return listView;
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sanjagh_flutter: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sanjagh_flutter/sanjagh_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:sanjagh_flutter/sanjagh_flutter.dart]

Package does not support Flutter platform macos

Because of import path [package:sanjagh_flutter/sanjagh_flutter.dart]

Package does not support Flutter platform web

Because of import path [package:sanjagh_flutter/sanjagh_flutter.dart]

Package does not support Flutter platform windows

Because of import path [package:sanjagh_flutter/sanjagh_flutter.dart]

Package not compatible with SDK dart

because of import path [sanjagh_flutter]

Health suggestions

Fix lib/sanjagh_flutter.dart. (-0.50 points)

Analysis of lib/sanjagh_flutter.dart reported 1 hint:

line 239 col 5: Avoid empty statements.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://sanjagh.com/ was unreachable.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test