saka_image 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 11

saka_image #

A flutter image widget,can use placeholder before loading net_image, also can show an error image if there is something wrong with the image url

Getting Started #

just like use Image.network

SakaImage.urlWithPlaceHolder(
  "http://img.rangaofei.cn/01b18.jpg",
  prePlaceHolder: "images/test.gif",
  errPlaceHolder: "images/error.jpeg",
  preDuration: Duration(seconds: 10),
);

prePlaceHolder is used before load the net image

errPlaceHolder is user when the url not correct

preDuration is the prePlaceHolder show duration at least

other property is just like Image

  1. with no duration,when the net image get completed, the pre placeholder will be placed immediately.
SakaImage.urlWithPlaceHolder(
  "http://img.rangaofei.cn/01b18.jpg",
  errPlaceHolder: "images/error.jpeg",
  prePlaceHolder: "images/splash.jpg",
  fit: BoxFit.cover,
);
  1. with duration,when the net image get completed before the duration, the placeholder will not be placed until the duration.
SakaImage.urlWithPlaceHolder(
  "http://img.rangaofei.cn/01b18.jpg",
  errPlaceHolder: "images/error.jpeg",
  prePlaceHolder: "images/splash.jpg",
  preDuration: Duration(seconds: 5),
  fit: BoxFit.cover,
);
  1. if the url is not reachable or error, this will be replaced by the error.jpeg
SakaImage.urlWithPlaceHolder(
  "http://img.rangaofei.cn/01b18.jp",//errorr
  errPlaceHolder: "images/error.jpeg",
  prePlaceHolder: "images/splash.jpg",
  preDuration: Duration(seconds: 5),
  fit: BoxFit.cover,
);

the placeholder must be an assets url

[0.0.4] - 2018.12.10

fix the url is not correct but not show the errPlaceHolder bug

[0.0.1] - 2018.12.1

just first

example/README.md

example #

this is just a simple Image that can use prePlaceHolder and errPlaceHolder.

Getting Started #

just use like Image:

SakaImage.urlWithPlaceHolder(
  "http://img.rangaofei.cn/01b18.jpg",
  errPlaceHolder: "images/error.jpeg",
  prePlaceHolder: "images/splash.jpg",
  preDuration: Duration(seconds: 5),
  fit: BoxFit.cover,
);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  saka_image: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:saka_image/saka_image.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
2
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
11
Learn more about scoring.

We analyzed this package on Nov 5, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms:

Low code quality prevents platform classification.

Health issues and suggestions

Fix lib/src/image_stream.dart. (-94.37 points)

Analysis of lib/src/image_stream.dart failed with 10 errors, including:

line 135 col 3: 'SakaImageStreamCompleter.addListener' ('void Function(void Function(ImageInfo, bool), {onChange: void Function(ImageType), onError: void Function(dynamic, StackTrace)})') isn't a valid override of 'ImageStreamCompleter.addListener' ('addListener').

line 141 col 23: The argument type 'ImageListenervoid Function(ImageInfo, bool)' can't be assigned to the parameter type 'ImageStreamListener'.

line 141 col 33: The named parameter 'onError' isn't defined.

line 145 col 3: 'SakaImageStreamCompleter.removeListener' ('void Function(void Function(ImageInfo, bool))') isn't a valid override of 'ImageStreamCompleter.removeListener' ('removeListener').

line 147 col 26: The argument type 'ImageListenervoid Function(ImageInfo, bool)' can't be assigned to the parameter type 'ImageStreamListener'.

Fix lib/src/image_provider.dart. (-68.83 points)

Analysis of lib/src/image_provider.dart failed with 4 errors, 3 hints, including:

line 34 col 11: The argument type 'String' can't be assigned to the parameter type 'DiagnosticsNode'.

line 37 col 11: The argument type 'Null Function(StringBuffer)' can't be assigned to the parameter type 'Iterable

line 70 col 9: The argument type 'Null Function(StringBuffer)' can't be assigned to the parameter type 'Iterable

line 129 col 9: The argument type 'Null Function(StringBuffer)' can't be assigned to the parameter type 'Iterable

line 37 col 33: This function has a return type of 'Iterable

Format lib/saka_image.dart.

Run flutter format to format lib/saka_image.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/constant.dart (Run flutter format to format lib/src/constant.dart.)
  • lib/src/main_image.dart (Run flutter format to format lib/src/main_image.dart.)
  • lib/src/raw_image.dart (Run flutter format to format lib/src/raw_image.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test