rxbus 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 79

FlutterRxBus #

A Flutter EventBus using RxDart

Pub Package Pub Package

GitHub | Pub |

Usage #

1. Add to pubspec.yaml #

  rxbus: latest version

2. Define Event #

Any Dart class or List or any Data can be used as an event.

class ChangeTitleEvent {
  String title;


3. Register RxBus #

Register RxBus

import 'package:rxbus/rx_bus.dart';

RxBus.singleton.register<ChangeTitleEvent>().listen((event) {
      ยทยทยท//do something

4. Send Event #

Register listeners for specific events:

 RxBus.singleton.post(ChangeTitleEvent("Changed by event"));

License #

The MIT License (MIT)

0.0.2 #

fix event destroy bug

0.0.1 #

  • TODO: Describe initial release.


rxbus_example #

Demonstrates how to use the rxbus plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rxbus: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rxbus/rxbus.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/rxbus.dart. (-1.49 points)

Analysis of lib/rxbus.dart reported 3 hints:

line 7 col 18: Close instances of dart.core.Sink.

line 7 col 18: Name non-constant identifiers using lowerCamelCase.

line 39 col 24: This function has a return type of 'Observable

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
rxdart ^0.20.0 0.20.0 0.23.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8