rx_shared_preference 1.0.3+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

Deprecate. This package is now named rx_shared_preferences. Please use new name package, thanks.

1.0.3+1 - Aug 24, 2019 #

  • Deprecate this package

1.0.3 - Aug 24, 2019 #

  • Internal refactor

1.0.2 - Jul 24, 2019 #

  • Update dependencies (rxdart and shared_preferences) to latest version

1.0.1 - Jul 6, 2019 #

  • Update dependencies (rxdart and shared_preferences) to latest version

  • Add reload method

  • Some minor changes

1.0.0+2 - April 28, 2019 #

  • Update README.md

1.0.0+1 - April 27, 2019 #

  • Add test

1.0.0 - April 15, 2019 #

  • Refactor and add comment for public API.
  • Add example.

0.0.9 - April 14, 2019 #

  • Initial

example/README.md

Build ListView from Stream using RxSharedPreferences #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rx_shared_preference: ^1.0.3+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rx_shared_preference/rx_shared_preference.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/rx_shared_preference.dart.

Run flutter format to format lib/rx_shared_preference.dart.

Format lib/src/logger/logger_adapter.dart.

Run flutter format to format lib/src/logger/logger_adapter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
rxdart ^0.22.1 0.22.3
shared_preferences ^0.5.3+4 0.5.3+4
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
test_api ^0.2.4