rx_ble 0.5.4

Sponsor pub package

Flutter Rx BLE #

A Flutter BLE plugin, based on the wonderful RxAndroidBle and RxBluetoothKit libraries.

Batteries included. #

  • Acquire every permission and setting required for Bluetooth access, using a single method - RxBle.requestAccess().
  • No need to manually discover BLE services.
  • Automatically queues up GATT requests to avoid race conditions.

Installation #

iOS #

  1. Open iOS module in XCode
  2. Edit Info.plist
  3. Right click > Enable show Raw Keys/Values
  4. Add these entries
    • NSLocationWhenInUseUsageDescription = Please enable location to continue.
    • NSBluetoothPeripheralUsageDescription = Please enable bluetooth to continue.

Or, you may add these entries maually using your editor of choice:

<dict>
    ...

    <key>NSLocationWhenInUseUsageDescription</key>
    <string>Please enable location to continue.</string>
    <key>NSBluetoothPeripheralUsageDescription</key>
    <string>Please enable bluetooth to continue.</string>
</dict>

example/README.md

rx_ble_example #

Demonstrates how to use the rx_ble plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rx_ble: ^0.5.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rx_ble/rx_ble.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/src/exceptions.dart.

Run flutter format to format lib/src/exceptions.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
plugin_scaffold ^1.0.1 1.1.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin