routingkit 0.2.1 copy "routingkit: ^0.2.1" to clipboard
routingkit: ^0.2.1 copied to clipboard

High-performance trie-node router. It is based on Trie-Node and supports dynamic, static, parameter, wildcard routing, etc.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add routingkit

With Flutter:

 $ flutter pub add routingkit

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  routingkit: ^0.2.1

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:routingkit/routingkit.dart';
3
likes
140
pub points
34%
popularity

Publisher

verified publisherodroe.com

High-performance trie-node router. It is based on Trie-Node and supports dynamic, static, parameter, wildcard routing, etc.

Repository (GitHub)
View/report issues

Topics

#routing #router #routing-kit #trie #trie-node

Documentation

API reference

Funding

Consider supporting this project:

github.com

License

MIT (LICENSE)

Dependencies

logging

More

Packages that depend on routingkit