route_provider 2.0.5

  • Readme
  • Changelog
  • Installing
  • 47

dart-routeprovider #

[![Join the chat at https://gitter.im/4stern/dart-routeprovider](https://badges.gitter.im/Join%20Chat.svg)](https://gitter.im/4stern/dart-routeprovider?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge) Build Status Stories in Ready

Installation #

Add it to your dependencies

dependencies:
  route_provider: any

and install the package

$ pub get

Usage #

import 'dart:io';
import 'package:route_provider/route_provider.dart';
main() {
    HttpServer.bind(InternetAddress.loopbackIPv4,8080).then((HttpServer server){
        new RouteProvider(server, {
            "defaultRoute":"/",
            "staticContentRoot":"/docroot"
        })
        ..route(
            url: "/",
            controller: new EmptyRouteController(),
            responser: new FileResponse("docroot/index.html"),
            auth: new StaticAuth(authed: true)
        )
        ..route(
            url: "/impress",
            controller: new RestApiController(),
            responser: new FileResponse("docroot/impress.html"),
            auth: new StaticAuth(authed: true)
        )
        ..start();
    }).catchError((e) => print(e.toString()));
}

Contributing #

  1. Fork it!
  2. Create your feature branch: git checkout -b my-new-feature
  3. Commit your changes: git commit -am 'Add some feature'
  4. Push to the branch: git push origin my-new-feature
  5. Submit a pull request :D

Credits #

Robert Beyer 4sternrb@googlemail.com

License #

MIT

2.0.5 (2019-01-06) #

  • dependency update: increase mime_type to version ^0.2.2

2.0.4 (2019-01-06) #

  • if auth if null, we send an 401 instead of 403 now

2.0.3 (2019-01-05) #

  • Bugfixing

2.0.2 (2019-01-05) #

  • Bugfixing

2.0.1 (2019-01-05) #

  • Bugfixing

2.0.0 (2019-01-05) #

  • change to dart 2.1.0

1.0.1 (2018-01-14) #

  • remove basepath handling while static-content detection

1.0.0 (2018-01-14) #

  • add RedirectResponse to make simple redirects
  • dependency upgrade: increase mime_type to version 0.2.1
  • add enviroment sdk constraint to dart ">=1.8.0 <2.0.0"

0.3.6 (2016-05-13) #

  • add WebSocketController for handle websockets

0.3.5 (2016-05-13) #

  • add NoneResponse responsehandler

0.3.4 (2015-10-21) #

  • add AuthResponse to ApiRestController

0.3.3 (2015-10-16) #

  • change auth signature and handling

0.3.2 (2015-10-16) #

  • update tests

0.3.1 (2015-10-16) #

  • parsing http-request and params to auth handler

0.3.0 (2015-10-16) #

  • add the optional named parameter 'auth' (interface Auth) to the route method for authentication possibilities. it checks before the controller and responsehandler do there work if the call is authenticated - default is true.

0.2.0 (2015-08-27) #

  • rename RouteControllerEmpty to EmptyRouteController
  • add JsonResponser
  • add ApiRestController
  • change method signature of .route by using named parameters instead of map

0.1.13 #

  • Adding helfer functions to route-controller for parsing body-data like post-values

0.1.9 (2015-05-03) #

Feature:

  • add RouteError for transporting http-status-codes and messages to this layer; to handle error output not for your own

0.1.7 (2015-05-03) #

Feature:

  • add async/await handling

0.1.6 (2015-04-24) #

Feature:

  • RouteControllers execute-methode gets the request as parameter

Test:

  • add await expressions and async methods

0.1.5 (2015-04-23) #

Feature:

  • FileResponseHandler now sends file content as stream to response (@4stern)

0.1.4 (2015-04-23) #

Tests:

  • adding testfile to test the provider (@4stern)

Bugfixes:

  • fix content root bug (@4stern)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  route_provider: ^2.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:route_provider/route_provider.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
52
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
71
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Nov 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:route_provider/route_provider.dart with components: io.

Health issues and suggestions

Fix lib/src/route_controller.dart. (-27.22 points)

Analysis of lib/src/route_controller.dart failed with 1 error, 6 hints, including:

line 56 col 27: The argument type 'Utf8Decoder' can't be assigned to the parameter type 'StreamTransformer<Uint8List, dynamic>'.

line 54 col 32: Unnecessary new keyword.

line 63 col 19: Unnecessary new keyword.

line 79 col 59: Don't explicitly initialize variables to null.

line 79 col 84: Use = to separate a named parameter from its default value.

Document public APIs. (-0.22 points)

73 out of 75 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/controllers/RestApiController.dart. (-14.39 points)

Analysis of lib/src/controllers/RestApiController.dart reported 31 hints, including:

line 7 col 61: Don't explicitly initialize variables to null.

line 7 col 86: Use = to separate a named parameter from its default value.

line 8 col 15: Unnecessary new keyword.

line 10 col 57: Don't explicitly initialize variables to null.

line 10 col 82: Use = to separate a named parameter from its default value.

Fix lib/route_provider.dart. (-9.99 points)

Analysis of lib/route_provider.dart reported 21 hints, including:

line 22 col 48: Unnecessary new keyword.

line 23 col 47: Unnecessary new keyword.

line 24 col 31: Unnecessary new keyword.

line 29 col 19: Use = to separate a named parameter from its default value.

line 35 col 26: Unnecessary new keyword.

Fix additional 8 files with analysis or formatting issues. (-6.45 points)

Additional issues in the following files:

  • lib/src/controllers/WebSocketController.dart (6 hints)
  • lib/src/responsehandlers/JsonResponse.dart (4 hints)
  • lib/src/responsehandlers/file_response.dart (2 hints)
  • lib/src/auth/AuthInterface.dart (1 hint)
  • lib/src/errors/route_error.dart (Run dartfmt to format lib/src/errors/route_error.dart.)
  • lib/src/response_handler.dart (Run dartfmt to format lib/src/response_handler.dart.)
  • lib/src/responsehandlers/NoneResponse.dart (Run dartfmt to format lib/src/responsehandlers/NoneResponse.dart.)
  • lib/src/responsehandlers/RedirectResponse.dart (Run dartfmt to format lib/src/responsehandlers/RedirectResponse.dart.)

Maintenance suggestions

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and route_provider.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
mime_type ^0.2.2 0.2.4
Dev dependencies
build_runner >=0.8.10 <2.0.0
build_web_compilers >=0.3.6 <2.0.0