rich_textfield 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 24

rich_textfield #


The example screen shot

使用方法 #

import 'package:rich_textfield/rich_textfield.dart';
MyTextEditingController _editCtrl = new MyTextEditingController(
  topicStyle: new TextStyle(
    fontWeight: FontWeight.bold,
    color: Colors.yellow
  atStyle: new TextStyle(
    fontWeight: FontWeight.bold,
  emojiImgSourceType: EmojiImgSourceType.asset

Widget ret = new MyTextField(
  controller: _editCtrl,
  focusNode: _focusNode,
  style: new TextStyle(
    fontSize: 20,
    color: const Color.fromARGB(255, 180, 180, 180)

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.


hello_rich #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rich_textfield: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rich_textfield/rich_textfield.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Fix lib/edit/my_text_selection.dart. (-68.36 points)

Analysis of lib/edit/my_text_selection.dart failed with 4 errors:

line 202 col 46: 6 positional argument(s) expected, but 4 found.

line 202 col 71: The argument type 'Offset' can't be assigned to the parameter type 'double'.

line 202 col 81: The argument type 'TextSelectionDelegate' can't be assigned to the parameter type 'Offset'.

line 262 col 84: The getter 'handleSize' isn't defined for the class 'TextSelectionControls'.

Fix lib/edit/my_text_editing_controller.dart. (-57.81 points)

Analysis of lib/edit/my_text_editing_controller.dart failed with 3 errors:

line 338 col 38: The argument type 'void Function(ImageInfo, bool)' can't be assigned to the parameter type 'ImageStreamListener'.

line 339 col 32: The argument type 'void Function(ImageInfo, bool)' can't be assigned to the parameter type 'ImageStreamListener'.

line 349 col 34: The argument type 'void Function(ImageInfo, bool)' can't be assigned to the parameter type 'ImageStreamListener'.

Fix lib/edit/my_editable_text.dart. (-43.75 points)

Analysis of lib/edit/my_editable_text.dart failed with 2 errors:

line 398 col 7: Missing concrete implementations of 'TextInputClient.connectionClosed', 'TextInputClient.updateFloatingCursor', 'getter TextSelectionDelegate.copyEnabled', 'getter TextSelectionDelegate.cutEnabled', and 2 more.

line 862 col 28: The method 'reparentIfNeeded' isn't defined for the class 'FocusScopeNode'.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/edit/my_editable.dart (Run flutter format to format lib/edit/my_editable.dart.)
  • lib/edit/my_text_field.dart (Run flutter format to format lib/edit/my_text_field.dart.)
  • lib/info.dart (Run flutter format to format lib/info.dart.)
  • lib/rich_textfield.dart (Run flutter format to format lib/rich_textfield.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated.

The package was last published 52 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies