revolver 1.3.0

  • Readme
  • Changelog
  • Installing
  • 0

Automatically reloads your command line application when changes to files are detected. Monitoring occurs on files within the current path, recursively.

Check the documentation for extra functionality using the API.

Revolver was influenced by Nodemon.

Installation #

pub global activate revolver

Usage #

revolver [options...] application [application arguments...]
$ revolver --help
-e, --ext                 Watch only the specified extensions.
-w, --working-dir         Overrides the current working directory,.
                          (defaults to "/files/projects/dart/revolver")

-p, --use-polling         Using file polling, rather than file system events, to detect file changes.
-h, --help                Displays this help information.
-g, --[no-]git            Ignores git files and respects the contents of .gitignore.
                          (defaults to on)

-d, --[no-]ignore-dart    Ignore dart project files.
                          (defaults to on)

Examples #

$ revolver --ext="dart,yaml,conf" application.dart
Start.     application.dart
Modified.  application.dart
Reload.    application.dart
$ revolver --git bin/server.dart -p 8080
Start.     bin/server.dart
New File.  bin/test1
Reload.    bin/server.dart
Deleted.   bin/test1
Reload.    bin/server.dart
Version 1.0.0 #
  • Initial release.
Version 1.0.1 #
  • Fixed issue with displaying usage.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate revolver

2. Use it

The package has the following executables:


$ revolver

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  revolver: ^1.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:revolver/revolver.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0