rethinkdb_driver 2.3.2+2

Build Status

Dart RethinkDB Driver #

A Dart driver for RethinkDB v2.3.

Getting Started: #

The driver api tries to align with the javascript and python RethinkDB drivers. You can read their documentation here.

to include this driver in your own project add the package to your pubspec.yaml file:

dependencies:
  rethinkdb_driver: '^2.3.2+2'

or to use bleeding edge:

dependencies:
  rethinkdb_driver:
    git: git://github.com/billysometimes/rethinkdb.git

or if you are a developer:

  dependencies:
    rethinkdb_driver:
      path: /path/to/your/cloned/rethinkdb_driver

then import the package into your project:

    import 'package:rethinkdb_driver/rethinkdb_driver.dart';

to run tests execute the following command from the project root:

warning: tests are run against a live database, but they do attempt to clean up after themselves

  pub run test  

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rethinkdb_driver: ^2.3.2+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rethinkdb_driver/rethinkdb_driver.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
18
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0