responsive_flutter 0.0.3

responsive_flutter #

PRs Welcome

A Flutter package for scaling the size your apps UI and fontSize across different sized devices, insipired from react-native-size-matters and react-native-responsive-dimensions

Installation #

You just need to add responsive_flutter as a dependency in your pubspec.yaml file.

dependencies:
  responsive_flutter: ^0.0.2

Usage #


// Inside build function to pass context

@override
  Widget build(BuildContext context) {
    return Container(
        color: Colors.red,
        width: ResponsiveFlutter.of(context).scale(120),
        height: ResponsiveFlutter.of(context).verticalScale(100),
        padding: EdgeInsets.all(ResponsiveFlutter.of(context).moderateScale(8)),
        child: Text("Responsive flutter",
            style: TextStyle(fontSize: ResponsiveFlutter.of(context).fontSize(3))));
  }

Functions #

  • wp(double percentage)
    Will return the percentage of the screen's width.

    // Example 20% of screen's width
    ResponsiveFlutter.of(context).wp(20)
    
  • hp(double percentage)
    Will return the percentage of the screen's height.

    // Example 20% of screen's height
    ResponsiveFlutter.of(context).hp(20)
    
  • fontSize(double size)
    Will return fontSize that occupies exactly size% of the screen size.

  • scale(double size)
    Will return linear scaled result of the provided size, based on your device's screen width.

  • verticalScale(double size)
    Will return linear scaled result of the provided size, based on your device's screen height.

  • moderateScale(double size, [double factor]) Sometimes you don't want to scale everything in a linear manner, that's where moderate scale comes in.
    The cool thing about it is that you can control the resize factor (default is 0.5).
    If normal scale will increase your size by +2X, moderateScale will only increase it by +X, for example:
    ➡️ scale(10) = 20
    ➡️ moderateScale(10) = 15
    ➡️ moderateScale(10, 0.1) = 11

[0.0.3] - July 2019.

  • Fixed type issue with moderateScale function.

[0.0.2] - June 2019.

  • Added wp(double size) and hp(double size) functions to get percentage of the screen's width/height.

[0.0.1] - June 2019.

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  responsive_flutter: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:responsive_flutter/responsive_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
44
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and responsive_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test