responsive_assistant 0.0.7

  • Readme
  • Changelog
  • Installing
  • new58

Responsive Assistant #


A simple dart package that helps you to implement responsiveness.

The package was created based on Filled Stacks' approach.


Overview #

The package consists of the following:

  • DeviceScreenType - it is the simple enum that is used to determine type of the screen like desktop, tablet or mobile.

  • SizingInformation - this class is used to return information about Orientation, DeviceScreenType, ScreenSize and LocalWidgetSize.

  • ResponsiveAssistant - this is the the simple StatelessWidget that returns a widget with the SizingInformation.

Note: DeviceScreenType and SizingInformation is used by ResponsiveAssistant. You just need to use ResponsiveAssitant to control responsiveness.


Example #

The following example demonstrates the usecase of ResponsiveAssitant:

class MyHomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return ResponsiveAssistant(
      builder: (context, sizingInformation) {
        return Scaffold(
          body: Column(
            children: [
              Container(
                height: sizingInformation.screenSize.height * 0.2,
                color: Colors.blueGrey,
              ),
              Container(
                height: sizingInformation.screenSize.height * 0.3,
                color: Colors.blue,
              ),
              Container(
                height: sizingInformation.screenSize.height * 0.5,
                color: Colors.pink,
              ),
            ],
          ),
        );
      },
    );
  }
}

As you can see, we can get different information from sizingInformation field.

Or, you can use ResponsiveAssistant to calculate local widget size:

class MyHomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Column(
        children: [
          Container(
            height: 300,
            color: Colors.blueGrey,
            child: ResponsiveAssistant(
              builder: (context, sizingInformation) {
                return Center(
                  child: Container(
                    color: Colors.red,
                    height: sizingInformation.localWidgetSize.height * 0.8,
                    width: sizingInformation.localWidgetSize.width * 0.8,
                  ),
                );
              },
            ),
          ),
        ],
      ),
    );
  }
}

Dart Versions #

  • Dart 2: >= 2.6.0

Maintainers #

[0.0.7] - 06.23.2020 #

  • Documentation is added.

[0.0.5] - 06.22.2020 #

  • ResponsiveAssistant is added.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  responsive_assistant: ^0.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:responsive_assistant/responsive_assistant.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
24
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • responsive_assistant that is a package requiring null.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and responsive_assistant.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test