rencode 0.0.3

dart-rencode #

Rencoding implementation in dart.

Rencoding is a more complicated version of bencoding used by the Deluge torrent client and its RPC APIS.

It produces smaller encoding for small inputs than the original bencode.


You probably don't need this unless you are writing a Deluge RPC client.

[0.0.1] - 2018-03-29

  • Initial release

[0.0.2] - 2018-06-24

  • Dart 2 fixes.

[0.0.3] - 2018-09-22

  • Updated dependencies

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rencode: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rencode/rencode.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/rencode.dart. (-9.08 points)

Analysis of lib/rencode.dart reported 19 hints, including:

line 49 col 12: Unnecessary new keyword.

line 54 col 12: Unnecessary new keyword.

line 63 col 15: Unnecessary new keyword.

line 86 col 13: Unnecessary new keyword.

line 125 col 20: Unnecessary new keyword.

Maintenance suggestions

Package is getting outdated. (-39.18 points)

The package was last published 72 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and rencode.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test ^1.3.3