rencode 0.0.3

dart-rencode #

Rencoding implementation in dart.

Rencoding is a more complicated version of bencoding used by the Deluge torrent client and its RPC APIS.

It produces smaller encoding for small inputs than the original bencode.

Note

You probably don't need this unless you are writing a Deluge RPC client.

[0.0.1] - 2018-03-29

  • Initial release

[0.0.2] - 2018-06-24

  • Dart 2 fixes.

[0.0.3] - 2018-09-22

  • Updated dependencies

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rencode: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rencode/rencode.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:rencode/rencode.dart.

Health suggestions

Format lib/rencode.dart.

Run dartfmt to format lib/rencode.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and rencode.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test ^1.3.3

Admin