remote_ip_camera 1.0.0

remote_image_button #

Flutter widget to manage an image button UI from a JSON definition

This is a Remote UI plugin.

Usage #

Add the factory to the RemoteManagerWidget:

RemoteManagerWidget(
    parsers: [RemoteIpCameraFactory()],
    child: RemoteWidget(...)
)

Then you can provide a JSON representation of a color picker like this:

{
    'type': 'camera',
    'id': 'camera',
    'stream': 'http://domain.com/stream',
    'preview': 'http://domain.com/preview'
}

API #

Image button:

id : id of the widget value : current value, it has to match one of the values entries width : width of the button height: height of the button fit: fit, default to contain (1), see BoxFit for more padding: padding of the button, see EdgeInsets definition values: map of possible value

[1.0.0] - 16/09/2019.

  • initial release.

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  remote_ip_camera: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:remote_ip_camera/remote_ip_camera.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
24
Learn more about scoring.

We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Flutter SDK version is 1.7.8+hotfix.3.
 
 Because remote_ip_camera depends on flutter_hooks ^0.5.0 which requires Flutter SDK version >=1.0.0 <1.5.8, version solving failed.

Health suggestions

Format lib/src/parsers/ip_camera.dart.

Run flutter format to format lib/src/parsers/ip_camera.dart.

Format lib/src/remote_ip_camera.dart.

Run flutter format to format lib/src/remote_ip_camera.dart.

Format lib/src/widgets/ip_camera.dart.

Run flutter format to format lib/src/widgets/ip_camera.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0

Admin