redux_sqlite 0.0.2

  • Readme
  • Changelog
  • Installing
  • 28

redux_sqlite #

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  redux_sqlite: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:redux_sqlite/redux_sqlite.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
92
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
2
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:redux_sqlite/redux_sqlite.dart, package:redux_sqlite/sqlite.dart, package:path_provider/path_provider.dart]

Package does not support Flutter platform macos

Because of import path [package:redux_sqlite/redux_sqlite.dart, package:redux_sqlite/sqlite.dart, package:path_provider/path_provider.dart]

Package does not support Flutter platform web

Because of import path [package:redux_sqlite/redux_sqlite.dart, package:redux_sqlite/sqlite.dart, package:path_provider/path_provider.dart]

Package does not support Flutter platform windows

Because of import path [package:redux_sqlite/redux_sqlite.dart, package:redux_sqlite/sqlite.dart, package:path_provider/path_provider.dart]

Package not compatible with SDK dart

because of import path [redux_sqlite]

Health issues and suggestions

Document public APIs. (-1 points)

75 out of 75 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/redux_sqlite.dart. (-5.84 points)

Analysis of lib/redux_sqlite.dart reported 12 hints, including:

line 58 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 60 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 63 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 65 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 67 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/sqlite.dart. (-1.49 points)

Analysis of lib/sqlite.dart reported 3 hints:

line 71 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 101 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 135 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (path_provider, redux).

Package is getting outdated. (-41.37 points)

The package was last published 73 weeks ago.

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and redux_sqlite.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
path ^1.6.2 1.7.0
path_provider ^0.5.0 0.5.0+1 1.6.11
redux ^3.0.0 3.0.0 4.0.0
sqflite ^1.0.0 1.3.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
sqflite_common 1.0.2+1
synchronized 2.2.0+1
typed_data 1.1.6 1.2.0
vector_math 2.0.8