redurx_persist_web 0.9.0

redurx_persist_web pub package

Web Storage Engine for redurx_persist.

Saves to localStorage.

Usage #

final persistor = Persistor<AppState>(
  // ...
  storage: WebStorage(),
);

Key #

You can pass a key argument to WebStorage to set the key for localStorage.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.1.0 - 2019-02-05

  • Initial release redurx_persist_web.

0.8.0 - 2018-11-27

  • Release v0.8.0. Last v0.x release line.

0.8.0-rc.0 - 2018-11-06

  • Update to newest redux_persist (make match versions).

0.4.2 - 2018-03-14

  • Fix library export.

0.4.1 - 2018-03-10

  • Fix Future returning.

0.4.0 - 2018-03-10

  • Initial decoupling.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  redurx_persist_web: ^0.9.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:redurx_persist_web/redurx_persist_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
66
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and redurx_persist_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-2 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-1.64 points)

The package was last published 53 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <3.0.0
redurx_persist ^0.9.0 0.9.0
Transitive dependencies
meta 1.1.8
redurx 1.1.1
rxdart 0.20.0 0.23.1
synchronized 1.5.3+2 2.2.0