record_mp3 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

Record Mp3 #

pub package

Record an MP3 using the platform native API #

Depend on it #

Add this to your package's pubspec.yaml file:

dependencies:
  record_mp3: ^1.0.1

Usage #

iOS #

Make sure you add the following key to Info.plist for iOS

<key>NSMicrophoneUsageDescription</key>
<string>xxxxxx</string>

Example #

import 'package:record_mp3/record_mp3.dart';

//start record 
RecordMp3.instance.start(recordFilePath, (type) {
       // record fail callback
});
	  
//pause record
RecordMp3.instance.pause();

//resume record
RecordMp3.instance.resume();

//complete record and export a record file
RecordMp3.instance.stop();

1.0.0 #

  • Record an MP3 using the platform native API

1.0.0+1 #

  • Update documentation description

1.0.1 #

  • Add parameter type for fail callback function
  • Remove COMPLETE and ERROR status,Use IDEL status instead

example/README.md

record_mp3_example #

Demonstrates how to use the record_mp3 plugin.

Example #

import 'package:record_mp3/record_mp3.dart';

//start record 
RecordMp3.instance.start(recordFilePath, (type) {
       // record fail callback
});
	  
//pause record
RecordMp3.instance.pause();

//resume record
RecordMp3.instance.resume();


//complete record and export a record file
RecordMp3.instance.stop();


Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  record_mp3: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:record_mp3/record_mp3.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Dec 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test