reactor 0.1.2

  • Readme
  • Changelog
  • Installing
  • 56

Reactor #

Build Status

Reactor is a statically-typed Dart library for building user interfaces. Reactor wraps ReactJS.

Please Note: This package is in early stages of development and will change frequently while in major version 0

Getting Started #

These instructions will get you a copy of the project up and running on your local machine for development and testing purposes. See deployment for notes on how to deploy the project on a live system.

Prerequisites #

  • Dart 2.7.1 or higher

Running the example #

First:

pub get

Then:

webdev serve

Using in your project #

Coming Soon...

Running the tests #

pub run build_runner test

Built With #

  • Dart - The language
  • React - The wrapped JavaScript library

Versioning #

We use SemVer for versioning. For the versions available, see the tags on this repository.

Authors #

See also the list of contributors who participated in this project.

License #

This project is licensed under the MIT License - see the LICENSE.md file for details

Acknowledgments #

These projects are the true OG's of React in dart. Reactor would not exist without them. They have been strong inspiration points and together, Reactor and these projects, will continue to grow to make the react in dart community even stronger.

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

[Unreleased] #

[0.1.2] - 2020-04-08 #

Fixed #

  • build.yaml _localReactorBuilder config

[0.1.1] - 2020-03-07 #

Fixed #

  • Formatting.
    • ugh how embarassing...

[0.1.0] - 2020-03-07 #

Added #

  • Initial release of basic idea, much will change in version 0, I wouldn't depend on it.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reactor: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reactor/reactor.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jun 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev

Health suggestions

Fix lib/src/generator/component_generator.dart. (-1.49 points)

Analysis of lib/src/generator/component_generator.dart reported 3 hints:

line 38 col 28: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

line 45 col 53: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

line 45 col 104: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

Format lib/src/core/dom_components.dart.

Run dartfmt to format lib/src/core/dom_components.dart.

Format lib/src/core/maps/dom_props.dart.

Run dartfmt to format lib/src/core/maps/dom_props.dart.

Fix additional 14 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/core/maps/props.dart (Run dartfmt to format lib/src/core/maps/props.dart.)
  • lib/src/core/maps/ui_maps.dart (Run dartfmt to format lib/src/core/maps/ui_maps.dart.)
  • lib/src/core/react.dart (Run dartfmt to format lib/src/core/react.dart.)
  • lib/src/core/react/context.dart (Run dartfmt to format lib/src/core/react/context.dart.)
  • lib/src/core/react/hooks/use_effect.dart (Run dartfmt to format lib/src/core/react/hooks/use_effect.dart.)
  • lib/src/core/react/hooks/use_imperative_handle.dart (Run dartfmt to format lib/src/core/react/hooks/use_imperative_handle.dart.)
  • lib/src/core/react/hooks/use_reducer.dart (Run dartfmt to format lib/src/core/react/hooks/use_reducer.dart.)
  • lib/src/core/secret_internals.dart (Run dartfmt to format lib/src/core/secret_internals.dart.)
  • lib/src/generator/reactor_generator.dart (Run dartfmt to format lib/src/generator/reactor_generator.dart.)
  • lib/src/interop/component.dart (Run dartfmt to format lib/src/interop/component.dart.)
  • lib/src/interop/js.dart (Run dartfmt to format lib/src/interop/js.dart.)
  • lib/src/interop/js_backed_map.dart (Run dartfmt to format lib/src/interop/js_backed_map.dart.)
  • lib/src/interop/react.dart (Run dartfmt to format lib/src/interop/react.dart.)
  • lib/src/testing/utils.dart (Run dartfmt to format lib/src/testing/utils.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and reactor.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.1 <3.0.0
analyzer ^0.39.4 0.39.10
build ^1.2.2 1.3.0
dart_style >=0.1.7 <2.0.0 1.3.6
js ^0.6.1 0.6.1+1
meta ^1.1.7 1.1.8
pedantic ^1.8.0+1 1.9.0
source_gen ^0.9.4+2 0.9.5
Transitive dependencies
_fe_analyzer_shared 4.0.0
args 1.6.0
async 2.4.1
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
html 0.14.0+3
logging 0.11.4
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build_runner >=1.3.0 <2.0.0
build_test any
build_web_compilers >=1.2.0 <3.0.0
react_testing_library ^0.1.0
test ^1.3.4
test_html_builder ^1.0.0