reactive_sqflite 0.0.1

reactive_sqflite #

Reactive wrapper around sqflite database. Supports both iOS and Android.

  • Support insert, delete, update and quering
  • Return queries as rxdart Observables
  • Get updates for queries on insertions, deletions and updates

Transaction and batch execution is not yet supported.

Getting Started #

In your flutter project add the dependency:

dependencies:
  ...
  reactive_sqflite: any

For help getting started with Flutter, view the online documentation.

Usage #

Import reactive_sqflite.dart

import 'package:reactive_sqflite/reactive_sqflite.dart';

Read sqflite and rxdart documentation for further reference,

Example #

See the example directory for a sample.

0.0.1 #

Describe initial release. #

  • Insert, delete, update and query operations.
  • Transactions and batch execution are not yet supported

example/README.md

reactive_sqflite_example #

Demonstrates how to use the reactive_sqflite plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reactive_sqflite: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reactive_sqflite/reactive_sqflite.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
61
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Aug 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/reactive_database.dart. (-2.96 points)

Analysis of lib/reactive_database.dart reported 6 hints, including:

line 31 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 37 col 15: This function has a return type of 'FutureOr

line 55 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 62 col 15: This function has a return type of 'FutureOr

line 84 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Format lib/reactive_sqflite.dart.

Run flutter format to format lib/reactive_sqflite.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
rxdart ^0.20.0 0.20.0 0.22.1+1
sqflite ^1.0.0 1.1.6+3
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
path 1.6.4
sky_engine 0.0.99
synchronized 2.1.0+1
typed_data 1.1.6
vector_math 2.0.8