rave_flutter 0.0.8-alpha+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 76

Rave Flutter #

pub package

A robust Flutter plugin for accepting payment on Rave with

  • [x] Card
  • [ ] Bank Account
  • [ ] Mpesa
  • [ ] Ghana Mobile Money
  • [ ] Uganda Mobile Money

Keys #

Installation #

To use this plugin, add rave_flutter as a dependency in your pubspec.yaml file.

Webview is required so enable PlatformView on iOS by adding:


to Info.plist file

Making Payment #

Instantiate RavePayInitializer and pass it to RavePayManager.initialize along with the BuildContext. The result of the transaction is the Future returned by RavePayManager.initialize

processTransaction() async {
    // Get a reference to RavePayInitializer
    var initializer = RavePayInitializer(
        amount: 500, publicKey: publicKey, encryptionKey: encryptionKey)
      ..country = "NG"
      ..currency = "NGN"
      ..email = "customer@email.com"
      ..fName = "Ciroma"
      ..lName = "Adekunle"
      ..narration = narration ?? ''
      ..txRef = txRef
      ..subAccounts = subAccounts
      ..acceptMpesaPayments = acceptMpesaPayment
      ..acceptAccountPayments = acceptAccountPayment
      ..acceptCardPayments = acceptCardPayment
      ..acceptAchPayments = acceptAchPayments
      ..acceptGHMobileMoneyPayments = acceptGhMMPayments
      ..acceptUgMobileMoneyPayments = acceptUgMMPayments
      ..staging = true
      ..isPreAuth = preAuthCharge
      ..displayFee = shouldDisplayFee;

    // Initialize and get the transaction result
    RaveResult response = await RavePayManager()
        .initialize(context: context, initializer: initializer);

Documentation #

Documentation can be found here.

Contributing, Issues and Bug Reports #

The project is open to public contribution. Please feel very free to contribute. Experienced an issue or want to report a bug? Please, report it here. Remember to be as descriptive as possible.

0.0.8-alpha+1 #

  • Fixed issue with initializing payload with payment plan
  • Added error messages for payment methods that's under development

0.0.8-alpha #

  • Implemented a more robust card payment handling

0.0.7-alpha #

  • Implemented direct account debit of Nigerian banks

0.0.6-alpha+3 #

  • Added an explicit instruction not to close 3DS auth page

0.0.6-alpha+2 #

  • Fixed build issues

0.0.6-alpha+1 #

  • Updated dependencies to latest versions

0.0.6-alpha #

  • Added loading indicator for 3DS authentication web page

0.0.5-alpha #

  • Added a custom secured callback url
  • Fixed bugs with calling dot notations instead of cascade notation.

0.0.4-alpha #

  • Implemented callback urls for 3DS authentication

0.0.3-alpha #

  • Bumped version of dependencies

0.0.2-alpha #

  • Implemented card payment.

0.0.1-alpha.1 #

  • Initial release. Payment is not happening yet but the UI is somewhat ready.


rave_flutter_example #

Demonstrates how to use the rave_flutter plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rave_flutter: ^0.0.8-alpha+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rave_flutter/rave_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.4

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (equatable, flutter_svg).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
async ^2.3.0 2.4.0
dio ^3.0.3 3.0.7
equatable ^0.6.1 0.6.1 1.0.1
flutter 0.0.0
flutter_svg ^0.14.2 0.14.4 0.15.0
get_it ^3.0.1 3.0.3
http ^0.12.0+2 0.12.0+2
intl ^0.16.0 0.16.0
meta ^1.1.7 1.1.8
tripledes ^2.1.0 2.1.0
webview_flutter ^0.3.15+1 0.3.18+1
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
http_parser 3.1.3
path 1.6.4
path_drawing 0.4.1
path_parsing 0.1.4
pedantic 1.9.0
petitparser 2.4.0
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
xml 3.6.1
Dev dependencies