ranking 2.0.0 icon indicating copy to clipboard operation
ranking: ^2.0.0 copied to clipboard

A library to compute rankings of players. Uses ELO for dynamic rankings, and Bradley-Terry for static rankings.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add ranking

With Flutter:

 $ flutter pub add ranking

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  ranking: ^2.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:ranking/ranking.dart';
7
likes
120
pub points
43%
popularity

Publisher

unverified uploader

A library to compute rankings of players. Uses ELO for dynamic rankings, and Bradley-Terry for static rankings.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

More

Packages that depend on ranking