r_logger 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new74

r_logger #

A Flutter logger plugin.

Usage #

dependencies:
  r_logger: 

the first use this plugin , your need to init.

import 'packages:r_logger/r_logger.dart';

// [isWriteFile] can null,if you want to write log set to true,default false.
// [tag] can null.default RLogger.
// [filePath] not null your file path.
// [fileName] can null. default yyyy_MM_dd.
RLogger.initLogger(tag:'your tag',isWriteFile:true,filePath:'your file path',fileName:'your file name');

print info you can use.

RLogger.instance.d('Message');

print json you can use.

RLogger.instance.j('{"msg":"ok"}');

print error you can use.

RLogger.instance.e('message', error,stackTrace);

[0.1.0] - release

[0.1.1] - get score

[0.1.2] - get score again

example/README.md

r_logger_example #

import 'package:r_logger/r_logger.dart';

void main(){
  RLogger.initLogger();

  RLogger.instance.d('Hello World!');
  
  RLogger.instance.j('{"msg":"ok"}');
  
  RLogger.instance.e('your have a error', 'error object', StackTrace.current);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  r_logger: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:r_logger/r_logger.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Dec 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.4

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
intl ^0.16.0 0.16.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test