r_dart_library 0.2.1

  • Readme
  • Changelog
  • Installing
  • 44

r_dart_library #

dart pub package License: MIT

A core library of R.dart which is generated by Flr(Flutter-R) in flutter project.

dependency relationship table #

Because the Flutter SDK is currently in an unstable state, so I create the following dependency relationship table for developer to select the correct version of r_dart_library based on the relationship table and the Flutter SDK version of Flutter project.

由于Flutter SDK目前处于不稳定的状态,所以我创建了下面这个依赖版本关系表,让开发者根据这个关系表和Flutter项目的Flutter SDK版本选择r_dart_library的正确版本。

r_dart_library versionrequires Flutter SDK version
[0.1.0, 0.1.1]<1.10.15
[0.2.0, 0.2.1]>=1.10.15

use this package as a library #

  1. Depend on it

    Add this to your package's pubspec.yaml file:

     dependencies:
       r_dart_library:
         git:
           url: git@github.com:YK-Unit/r_dart_library.git
           ref: 0.1.0
    
  2. Install it You can install packages from the command line with Flutter:

    flutter pub get
    

    Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

  3. Import it

Now in your Dart code, you can use:

  import 'package:r_dart_library/asset_svg.dart';

For Flutter SDK Version: >=1.10.15 #

[0.2.1] - 2020-02-28

  • fix bug

[0.2.0] - 2019-12-25 BREAKING CHANGES

  • make compatible with the breaking change with ImageProvider.load in Flutter 1.10.15

For Flutter SDK Version: <1.10.15 #

[0.1.1] - 2020-02-28

  • fix bug

[0.1.0] - 2019-12-24

  • support SVG

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  r_dart_library: ^0.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:r_dart_library/asset_svg.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • r_dart_library that is a package requiring null.

Package not compatible with runtime flutter-web on Web

Because:

  • package:r_dart_library/asset_svg.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io

Health suggestions

Format lib/asset_svg.dart.

Run flutter format to format lib/asset_svg.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and r_dart_library.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_svg >=0.14.1 <1.0.0 0.17.4 0.18.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
meta 1.1.8 1.2.2
path_drawing 0.4.1
path_parsing 0.1.4
petitparser 3.0.4
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
xml 3.7.0 4.2.0
Dev dependencies
flutter_test