qyfk 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 36

网易七鱼的Flutter封装 V0.0.1 #

这只是一个简单的封装,功能不是很全,但是基本够用了。 如果有需要的功能可以给我提Issue。

使用方法见: qyfk 0.0.1

License #

LICENSE

0.0.1 #

  • TODO: Describe initial release.

example/README.md

qyfk_example #

Demonstrates how to use the qyfk plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  qyfk: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:qyfk/qyfk.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/qykf_flutter.dart. (-1.49 points)

Analysis of lib/qykf_flutter.dart reported 3 hints:

line 1 col 8: Unused import: 'dart:async'.

line 4 col 8: Unused import: 'package:flutter/gestures.dart'.

line 8 col 8: Unused import: 'package:qyfk/qykf_flutter.dart'.

Format lib/qyfk.dart.

Run flutter format to format lib/qyfk.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/cythb/QYKF-For-Flutter was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test