quiver_iterables 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • --

Quiver Iterables #

A collection of utilities for generating and manipulating Dart Iterables.

Build Status Coverage Status

Documentation #

API Docs

concat, count, cycle, enumerate, merge, partition, range, and zip create, transform, or combine Iterables in different ways, similar to Python's itertools.

min, max, and extent retrieve the minimum and maximum elements from an iterable.

GeneratingIterable is an easy way to create lazy iterables that produce elements by calling a function. A common use-case is to traverse properties in an object graph, like the parent relationship in a tree.

InfiniteIterable is a base class for Iterables that throws on operations that require a finite length.

1.0.0-dev.1 #

  • Split from quiver-dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  quiver_iterables: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:quiver_iterables/iterables.dart';
  
Version Uploaded Documentation Archive
1.0.1 Sep 7, 2017 Go to the documentation of quiver_iterables 1.0.1 Download quiver_iterables 1.0.1 archive
1.0.0+1 Sep 7, 2017 Go to the documentation of quiver_iterables 1.0.0+1 Download quiver_iterables 1.0.0+1 archive
1.0.0 Jan 13, 2016 Go to the documentation of quiver_iterables 1.0.0 Download quiver_iterables 1.0.0 archive
1.0.0-dev.1 Nov 18, 2015 Go to the documentation of quiver_iterables 1.0.0-dev.1 Download quiver_iterables 1.0.0-dev.1 archive
Awaiting analysis to complete.