quill_zefyr_bijection 0.3.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 75

Quill Zefyr Bijection #

A Flutter package that converts quill json to zefyr delta.

Example #

Delta d=QuillZefyrBijection.convertJSONToZefyrDelta('{
  "ops": [
    {
      "insert": "Gandalf the Grey\n"
    }
  ]
}');

v[0.0.1] #

  • first release
  • Add method that converts quill json to zefyr delta

v[0.1.0] #

  • added example

v[0.2.0] #

  • fixed image and added hr for dots

v[0.2.1] #

  • fixed error for embed

v[0.2.2] #

  • ignoring zefyr attributes

v[0.3.0] #

  • added zefyr to quill transform

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:zefyr_quill/HomePage.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  quill_zefyr_bijection: ^0.3.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:quill_zefyr_bijection/quill_zefyr_bijection.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
75
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • quill_zefyr_bijection that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
quill_delta ^1.0.2 1.0.2
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
quiver_hashcode 2.0.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test