qr_code_utils 0.0.1 icon indicating copy to clipboard operation
qr_code_utils: ^0.0.1 copied to clipboard

Flutter plugin that provides tools for dealing with QR code. For now, just read.

qr_code_utils #

pub package

A Flutter plugin that provides tools to deal with QR Codes.

Package based on: QRCodeTools

Instalation #

First, add qr_code_utils as a dependency in your pubspec.yaml file.

Android #

Nothing to do

iOS #

Add one rows to the ios/Runner/Info.plist:

  • one with the key Privacy - Photo Library Usage Description and a usage description.

Or in text format add the key:

<key>NSPhotoLibraryUsageDescription</key>
<string>Can I use the photo library please?</string>

Example #

import 'package:qr_code_utils/qr_code_utils.dart';

String _data;
/// decode from local file
Future decode(String file) async {
  String data = await QrCodeToolsPlugin.decodeFrom(file);
  setState(() {
    _data = data;
  });
}

For a more elaborate usage example see here.

1
likes
120
pub points
17%
popularity

Publisher

unverified uploader

Flutter plugin that provides tools for dealing with QR code. For now, just read.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, qr_code_utils_android, qr_code_utils_ios

More

Packages that depend on qr_code_utils