qr_code_pretty 1.2.0
qr_code_pretty: ^1.2.0 copied to clipboard

fast QR code rendering via a Widget or custom painter. You can round the edges with parameter or use the standard view.

qr_code_pretty #

fast QR code rendering via a Widget or custom painter. You can round the edges with parameter or use the standard view.

Features #

Screenshots #

Example #

import 'package:flutter/material.dart';
import 'package:qr_code_pretty/qr_code_pretty.dart';
import 'package:qr/qr.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        body: Center(
            child: QrCodePretty(
                image: AssetImage('images/man.png'),
                typeNumber: 10,
                size: 300,
                data: 'https://www.google.com',
                errorCorrectLevel: QrErrorCorrectLevel.M,
                roundEdges: true)),
      ),
    );
  }
}

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

3
likes
110
pub points
45%
popularity

fast QR code rendering via a Widget or custom painter. You can round the edges with parameter or use the standard view.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, qr

More

Packages that depend on qr_code_pretty