pusher_js 1.3.0

pusher #

A Dart wrapper for Pusher.js

Usage #

import 'package:pusher_js/pusher_js.dart';

main() {
  var socket = new Pusher('0eb73a235dd03b3df71a');
  socket.connection.bind('connected', allowInterop((data) {
    print('Connected to Pusher!');
  }));
}

Note: callbacks should be wrapped in allowInterop().

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

1.0.0 #

  • Initial version

1.0.1 #

  • rename to pusher_js

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pusher_js: ^1.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pusher_js/pusher_js.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
94
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: web, other

Primary library: package:pusher_js/pusher_js.dart with components: js.

Health suggestions

Fix lib/src/pusher_base.dart. (-6.31 points)

Analysis of lib/src/pusher_base.dart reported 13 hints, including:

line 31 col 1: Prefer using /// for doc comments.

line 36 col 1: Prefer using /// for doc comments.

line 41 col 1: Prefer using /// for doc comments.

line 47 col 1: Prefer using /// for doc comments.

line 53 col 1: Prefer using /// for doc comments.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-0.27 points)

The package was last published 52 weeks ago.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and pusher_js.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
js >=0.6.0 <0.7.0 0.6.1+1