pusher_flutter 0.0.8

  • Readme
  • Changelog
  • Example
  • Installing
  • 64

pusher_flutter #

A plugin for the Pusher service.

In active development for our internal use case. Once API is stable we will publish a 1.0.0 release. Not ready for production use.

Getting Started #

For help on editing plugin code, view the documentation.


  • Basic support for subscribing to channels, getting events, and getting connectivity info.


  • Sample project cleanup


  • README changes


  • Simplified API for receiving messages. Introduced PusherMessage model.


  • onMessage is now a getter instead of a method call
  • Added support for receiving pusher errors
  • Added support for passing in a cluster when creating a Pusher instance.


  • update for Dart 2


  • Fix android build errors after gradle update


  • Fix crash on Android related to this issue


pusher_flutter_example #

Demonstrates how to use the pusher_flutter plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  pusher_flutter: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:pusher_flutter/pusher_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/pusher_flutter.dart.

Run flutter format to format lib/pusher_flutter.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8