pure_mixpanel 1.0.9

  • Readme
  • Changelog
  • Installing
  • 17

pure_mixpanel #

A pure Dart library for Mixpanel analytics.

Running Tests #

This library has Flutter as a dependency for easier testability. The tests are true end to end tests, using a real Mixpanel account and API token that anyone is free to use. I decided against mocking the API for now to keep the codebase simple.

flutter test test/pure_mixpanel_test.dart

Features #

  • Event tracking

Upcoming Features #

[1.0.9] - 7/19/19

  • Allowed user to specifiy whether to show debug logs
  • Disabled sending events (by default) to Mixpanel during debugging.

[1.0.8] - 7/04/19

  • Updated Dart SDK constraints in pubspec
  • Updated all dependencies
  • Updated Flutter version to >= 1.0.0

[1.0.7] - 3/22/19

  • Update to work with Dart v2.2.1

[1.0.6] - 12/30/18

  • Upped versions to work with the latest version of Flutter.

[1.0.5] - 12/6/18

  • Support for optional IP tracking.

[1.0.2] - 7/9/18

  • Fix for siutations where debug flag isn't passed in constructor.

[1.0.1] - 7/8/18

  • Minor tweaks.

[1.0.0] - 7/7/18

  • Initial release, supporting Mixpanel event tracking.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pure_mixpanel: ^1.0.9

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pure_mixpanel/pure_mixpanel.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
17
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <=3.0.0