pubspec_lock_reader 1.0.2
pubspec_lock_reader: ^1.0.2 copied to clipboard

Reads pubspec.lock file from main directory and transfers the content into readable object.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add pubspec_lock_reader

With Flutter:

 $ flutter pub add pubspec_lock_reader

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  pubspec_lock_reader: ^1.0.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:pubspec_lock_reader/pubspec_lock_reader.dart';
0
likes
130
pub points
14%
popularity

Reads pubspec.lock file from main directory and transfers the content into readable object.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

universal_io, yaml

More

Packages that depend on pubspec_lock_reader