pubinit 0.0.4

  • Installing
  • Versions
  • 0

pubinit #

A simple dart command line utility to boostrap the pubspec.yaml file in a dart project

Inspired from the npm init command.

Install #

Just run pub global activate pubinit
pub global activate --source git

Usage #

Just run pub global run pubinit in the folder you want to create your pubspec.yaml

#Contributing Feel to free to send issues and merge request !

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate pubinit

2. Use it

The package has the following executables:

$ pubinit
Version Uploaded Documentation Archive
0.0.4 Apr 14, 2017 Go to the documentation of pubinit 0.0.4 Download pubinit 0.0.4 archive
0.0.3 Apr 14, 2017 Go to the documentation of pubinit 0.0.3 Download pubinit 0.0.3 archive
0.0.2 Apr 14, 2017 Go to the documentation of pubinit 0.0.2 Download pubinit 0.0.2 archive
0.0.1 Apr 14, 2017 Go to the documentation of pubinit 0.0.1 Download pubinit 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0