pub_util is a utility that can help list and update globally
installed outdated Dart packages.
The hope is that this functionality will eventually be available in the
pub global command.
pub global activate pub_util
pub_util can list all and outdated packages and update outdated packages.
All feedback, PRs and bug reports are welcome.
You can install the package from the command line:
$ pub global activate pub_util
The package has the following executables:
|0.0.3||Dec 2, 2016|
|0.0.2||Dec 2, 2016|
|0.0.1||Dec 2, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.13.0 <2.0.0|