Diagnoses version conflicts between dependencies in Dart packages.
mediator, it is rather cumbersome to resolve dependency conflicts within Dart projects.
You would receive a relatively cryptic error message that doesn't tell you much in the way of
Package jaguar_serializer has no versions that match >=0.3.0 <0.4.0 derived from: - gitter 0.1.1 depends on version ^0.3.0
mediator provides you with details about where the mismatches are:
✗ Found 1 dependency conflict: Found 2 mismatching dependencies on package:crypto: * foo requires <1.0.0 * angel_auth requires ^2.0.0
mediator also tracks nested dependencies. Dependency mismatches don't always happen at the
top level, but often within the dependencies of other dependencies.
✗ Found 1 dependency conflict: Found 2 mismatching dependencies on package:crypto: * foo requires <1.0.0 * bar->baz->quux requires ^2.0.0
Installation and Usage #
pub global activate pub_mediator
Run the following in your project root:
mediator # Enable verbose output mediator -v # Print help mediator -h
Use this package as an executable
1. Install it
You can install the package from the command line:
$ pub global activate pub_mediator
2. Use it
The package has the following executables:
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: pub_mediator: ^1.0.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.