prs_utility_dart 0.1.0+1

  • Readme
  • Changelog
  • Installing
  • 59

prs_utility_dart #

prs-utility 是 PRS 提供的算法工具库,包含项目中需要使用的所有哈希、加密算法。

[0.0.1] - 2019/05/16 #

  • Initial version.

[0.1.0+1] - 2020/02/07 #

  • add sha256.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prs_utility_dart: ^0.1.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prs_utility_dart/prs_utility_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Apr 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

19 out of 19 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and prs_utility_dart.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
convert ^2.1.1 2.1.1
flutter 0.0.0
keccak ^1.0.3 1.0.3
meta ^1.1.8 1.1.8
pointycastle ^1.0.2 1.0.2
prs_utility_plugin ^0.0.1+12 0.0.1+12
typed_data ^1.1.6 1.1.6
uuid ^2.0.4 2.0.4
Transitive dependencies
charcode 1.1.3
collection 1.14.11 1.14.12
crypto 2.1.4
sky_engine 0.0.99
vector_math 2.0.8
Dev dependencies
flutter_test