proxy_kit 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new51

proxy_kit #

Build Status Codecov GitHub Tag Pub Package License

A powerful proxy plugin for Flutter.

android #

# 不需要做任何额外接入工作
# 不需要混淆

ios #

# 不需要做任何额外接入工作

flutter #

  • snapshot
dependencies:
  proxy_kit:
    git:
      url: https://github.com/v7lin/fake_proxy.git
  • release
dependencies:
  proxy_kit: ^${latestTag}

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

1.0.0 - 2020.6.25 #

  • v2

0.1.0 #

  • Android/iOS Proxy

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:proxy_kit/proxy_kit.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Proxy Kit'),
        ),
        body: ListView(
          children: <Widget>[
            ListTile(
              title: const Text('Proxy'),
              onTap: () async {
                String proxy = await Proxy.getProxy();
                print('proxy: ${proxy ?? ''}');
              },
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  proxy_kit: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:proxy_kit/proxy_kit.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:proxy_kit/proxy_kit.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:proxy_kit/proxy_kit.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:proxy_kit/proxy_kit.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:proxy_kit/proxy_kit.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • proxy_kit that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test
pedantic any