provider 4.3.2+2
provider: ^4.3.2+2

Flutter Android iOS web

A wrapper around InheritedWidget to make them easier to use and more reusable.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  provider: ^4.3.2+2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:provider/provider.dart';
2856
likes
110
pub points
100%
popularity

Publisher

dash-overflow.net

A wrapper around InheritedWidget to make them easier to use and more reusable.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, nested

More

Packages that depend on provider