provide 1.0.2
provide: ^1.0.2 copied to clipboard

A simple framework for state management in Flutter. This package contains classes to allow the passing of data down the widget tree.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add provide

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  provide: ^1.0.2

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:provide/provide.dart';
2
likes
100
pub points
86%
popularity

Publisher

Unknown

A simple framework for state management in Flutter. This package contains classes to allow the passing of data down the widget tree.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on provide