prompter_mh 0.0.6

  • README.md
  • Example
  • Installing
  • Versions
  • 38

prompter_mh #

prompter_mh is a dart CLI package for asking questions and retrieving the results. Flip on to the Example tab to see how it is used.

A Map<String, dynamic> of is available as result on your instance of the prompter. The String is the key specified to the ask method whiles dynamic is the value desired.

Supported prompt types

  • multiple: For asking multiple choice questions
  • binary: For asking boolean choice questions
  • text: For asking questions expecting text response

MIT LICENSE

example/main.dart

import 'package:prompter_mh/prompter_mh.dart';

void main() {
  // Instantiate a prompter instance
  Prompter prompter = Prompter();

  // Ask some questions
  prompter.ask(
    'color',
    'What Color Do You Want?',
    'multiple',
    [
      Option(label: 'I want red', value: '#f44141'),
      Option(label: 'I want blue', value: '#4158f4'),
      Option(label: 'I want green', value: '#42f47d'),
      Option(label: 'I want yellow', value: '#f4f441'),
    ]
  );

  prompter.ask(
    'likeBanana',
    'Do you like banana?',
    'binary',
    null,
  );

  prompter.ask(
    'name',
    'What is your name?',
    'text',
    null,
  );
  

  print(prompter.results);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_mh: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_mh/prompter_mh.dart';
  
Version Uploaded Documentation Archive
0.0.6 Dec 18, 2018 Go to the documentation of prompter_mh 0.0.6 Download prompter_mh 0.0.6 archive
0.0.5 Dec 17, 2018 Go to the documentation of prompter_mh 0.0.5 Download prompter_mh 0.0.5 archive
0.0.4 Dec 17, 2018 Go to the documentation of prompter_mh 0.0.4 Download prompter_mh 0.0.4 archive
0.0.3 Dec 17, 2018 Go to the documentation of prompter_mh 0.0.3 Download prompter_mh 0.0.3 archive
0.0.2 Dec 17, 2018 Go to the documentation of prompter_mh 0.0.2 Download prompter_mh 0.0.2 archive
0.0.1 Dec 17, 2018 Go to the documentation of prompter_mh 0.0.1 Download prompter_mh 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_mh/prompter_mh.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

12 out of 12 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/option.dart.

Run dartfmt to format lib/src/option.dart.

Format lib/src/prompter.dart.

Run dartfmt to format lib/src/prompter.dart.

Format lib/src/terminal.dart.

Run dartfmt to format lib/src/terminal.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0