prompter_mc 0.1.0

  • This is just a package used to learn Dart.
  • Library to create a CLI wizard.

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Integer eget nibh. Fusce odio orci, mattis nec, fringilla tincidunt, tincidunt sit amet, massa. Vestibulum laoreet orci a quam. Pellentesque porttitor. Aenean cursus turpis at ante. Nunc sed velit a enim tristique laoreet. Sed ornare tristique enim. Curabitur condimentum urna vitae dolor. Pellentesque magna mauris, semper vel, luctus sit amet, semper quis, ipsum. Vestibulum eu mi. Aliquam erat volutpat. Pellentesque et arcu. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Donec porttitor viverra turpis. Sed nec est id dolor malesuada vulputate.

First version.

0.1.0: Changes made according to health issues and suggestions given by pub.dev.

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Integer eget nibh. Fusce odio orci, mattis nec, fringilla tincidunt, tincidunt sit amet, massa. Vestibulum laoreet orci a quam. Pellentesque porttitor. Aenean cursus turpis at ante. Nunc sed velit a enim tristique laoreet. Sed ornare tristique enim. Curabitur condimentum urna vitae dolor. Pellentesque magna mauris, semper vel, luctus sit amet, semper quis, ipsum. Vestibulum eu mi. Aliquam erat volutpat. Pellentesque et arcu. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Donec porttitor viverra turpis. Sed nec est id dolor malesuada vulputate.

example/main.dart

import 'package:prompter_mc/prompter_mc.dart';

void main() {
  var options = [
    new Option('first option', 25),
    new Option('second option', 35),
    new Option('third option', 45),
  ];

  var prmptr = new Prompter();
  prmptr.clearScreen();
  var val = prmptr.askMany('Which option do you prefer?', options);
  print('Value: $val');
  bool bRet = prmptr.askYesNo('Do you like Dart?');
  print(bRet);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_mc: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_mc/prompter_mc.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
10
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Feb 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0